+ Rispondi
Pagina 1 di 6 1 2 3 ... UltimaUltima
Risultati da 1 a 10 su 53
  1. #1

    Iscritto dal
    11/12/2011
    Messaggi
    58

    [AIUTO] Led fine carica su caricabatterie

    Come dicevo pochi istanti fa, comincio ad approfittare subito di voi

    ho realizzato questo caricabatterie per batt al piombo, sulla stessa scheda ne ho messi 2 così posso ricaricare 2 batterie contemporaneamente.
    L'unica modifica che ho fatto è quella di aver messo un commutatore a 3 posizioni su R4 in modo da avere 3 limitazioni di corrente diverse. Ho previsto 130 mA, 260 mA e 360 mA.

    Lo schema è questo:



    Le batterie invece sono queste:




    Siccome il mio avvitatore aveva 2 pacchi batterie entrambi esausti, ma l'avvitatore è ancora nuovo e perfettamente funzionante, ho levato il pacco da 10 batte che stavano in serie e le ho sostituite con una sole di queste.


    Vengo al punto: vorrei mettere un led che indichi la fine della carica, pensavo di cavarmela con un transistor e 2 resistenze sfruttando la tensione che man mano sale ai capi della batteria fino a raggiungere il valore preimpostato, o anche quella che tende a zero su R4, ma mi è andata male ...forse ho fatto male i calcoli....bho.

    Qualcuno mi può dire come fare? Io sono paaaaarecchio arruginito

    Grazie.

  2. #2

    Iscritto dal
    09/12/2011
    Località
    Ciampino , Roma
    Messaggi
    146
    Ciao e benvenuto.
    Per favore , potresti :

    - mettere la forumla della relazione tra la corrente in uscita ed R4 ;
    - il trimmer R5 và regolato per avere 13.8 V in uscita senza carico , giusto ?

    Ciao.
    EX PcTuner Staff
    --------------------------------------
    Prima di scrivere , controlla che il cervello sia collegato
    La vita è una tempesta e prenderlo dove fà male è un lampo ( UCCELLONE DOCET )
    Il tempo è sempre poco , usalo bene
    Non polemizzare inutilmente e ricorda che esistono i PVT
    Rispetta e sarai rispettato ; non chiedere le tesine per la scuola , piuttosto proponi , lavora e sarai aiutato

  3. #3

    Iscritto dal
    11/12/2011
    Messaggi
    58
    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    Ciao e benvenuto.
    Per favore , potresti :

    - mettere la forumla della relazione tra la corrente in uscita ed R4 ;
    - il trimmer R5 và regolato per avere 13.8 V in uscita senza carico , giusto ?

    Ciao.
    Eilà, il grandissimo

    Grazie del benvenuto. Il mio nick non te lo ricordi? Ci conoscemmo anni fa su pct e tu mi mandasti a casa 2 diodi che non riuscivo a trovare da nessuna parte, non ricordo che diodi erano, mi pare bat41, andavano nel tuo circuito termoregolatore ventole. Che tempi! Si smanettava che era un piacere. Adesso il tempo è tiranno.

    In merito alle tue domande:

    - la R4 l'ho calcolata facendo 0.6 diviso la corrente desiderata. Ho però verificato che ai capi di questa resistenza, 0.6V non ci stanno mai, parte sempre da 0.55 o giù di lì per poi scendere man mano che la batt assorbe di meno. Lo 0.6 lo ottengo solo mettendo in corto l'uscita. Una cosa strana che ho notato però è che la batteria anche se scarica, assorbe sempre qualcosa in meno rispetto a quanto impostato con la resistenza.
    Mi spiego, se metto l'uscita in corto, l'amperometro misura perfettamente 130 mA, 260mA, 360mA. Se però collego la batteria, invece di assorbire ai valori da me impostati, assorbe 110mA, 230mA, 330mA mi pare, non ricordo di preciso.

    - si senza carico, ma in realtà non ho tarato a 13.8V ma a 14.6 perchè sulla batteria mi dice che va a 13.8 per carica tampone e da 14.3V-15V per uso ciclico.
    Essendo batterie che uso nell'avvitatore (una volta ogni tanto) ho pensato di mettere a 14.6V. Però se secondo te non va bene fammi sapere che adeguo l'uscita a quello che dici tu.


    Ah, un altro comportamento strano che ho verificato è che così com'è lo schema, l'uscita non è stabile, nel senso che dopo aver tarato l'uscita e fatto un po' di prove tra attacca e stacca ecc, all'improvviso mi ritrovo 3-4 volts in più sull'uscita, alchè c'ho piazzato una resistenza da 10M in parallelo all'uscita e così ho risolto, resta perfettamente stabilizzata. Immagino sia poco ortodosso, ma le mie conoscenze sono quelle che sono
    Onestamente, ho controllato e ricontrollato il circuito e non mi sembra di aver sbagliato, tra l'altro ne ho fatti 2 e si comportano uguale.

    Quando puoi, fammi sapere, in settimana non posso, ma il fine settimana mi metto di nuovo all'opera.


    Comunque grazie per l'interessamento e piacere di averti reincontrato.


    Edit: lo schema con tutta la spiegazione si trova facilmente in rete, se serve, e se posso, inserisco il link al sito esterno.

  4. #4

    Iscritto dal
    11/12/2011
    Messaggi
    58
    Voglio condividere con voi questa cosa, magari può essere utile a qualcuno.

    Come tutti sanno, il problema delle batterie che muoiono lasciando il trapano o l'avvitatore ancora perfettamente funzionante, è una cosa che capita molto molto spesso e ci ci si ritrova sempre a dover buttare tutto e ricomprare da capo, visto che una batteria originale, qualsiasi marca si prende, costa sempre quasi quanto all'intera valigetta, inoltre, voler ricostruire il pacco batterie interno, con celle uguali, nemmeno non è pensabile visto il costo di ogni singola cella.

    Per chi ha bisogno di un avvitatore hobbystico, che costi poco ma che va molto bene, il mio ha fatto tanto, ma tanto di quel lavoro in 3 anni... io consiglio un Valex 2120P, per il semplice motivo che il contenitore del pacco batterie ha la misura giusta giusta (ci va ad incastro, al decimo di millimetro) per infilarci una bella batta al piombo da 1.3A (il pacco originale è 1.2) che trovate in giro anche a 6 €, uguale a quelle che ho preso io. Con 6 euro, e un po' di lavoro, si recupera perfettamente il tutto. L'avvitatore è dotato di 2 batterie, quindi con 12 € si risolve perfettamente senza buttare via tutto...e poi vuoi mettere la soddisfazione?

    Batteria appena aperta:
    [AIUTO] Led fine carica su caricabatterie-img0491.jpg
    Pacco visto da vicino:
    [AIUTO] Led fine carica su caricabatterie-img0501.jpg

    Comodissimo il supporto dei contatti, basta tagliarlo e saldarci il cavo:
    [AIUTO] Led fine carica su caricabatterie-img0511.jpg


    Batteria inserita. Richiudendo il pacco non si nota assolutamente niente, tranne nel peso che è circa 150 grammi in più.
    [AIUTO] Led fine carica su caricabatterie-img0561.jpg
    Ultima modifica: 12-12-2011 alle 10:30, di Matthew

  5. #5

    Iscritto dal
    09/12/2011
    Località
    Ciampino , Roma
    Messaggi
    146
    Si , ora che mi dici dei diodi ricordo bene , scusami ma di acqua sotto i ponti ne è passata tanta , il tempo è tiranno pure per me e la mente non è più quella di una volta.
    Da come è fatto il circuito , è normale che si comporti nel modo detto da te ; gli 0.6 Volt che usi per il calcolo sono uno standard , nel senso che è il valore al quale il transitor dovrebbe iniziare a condurre ; quello tuo comincia a condurre prima , a 0.55 V , quindi ti falsa leggermente i calcoli.
    La resitenza in parallelo all'uscita mettila da 15 KOhm , anche se in teoria dovrebbe essere inutile , forse a causa dei fili parte una qualche auto-oscillazione , andrebbe fatta una verifica ma non credo sia importante.
    Ti allego una modifica da fare al circuito , ma devo fare un paio di premesse :

    - sono 5 anni , se non più , che non mi capita di progettare qualcosa , quindi quello che ti propongo potrebbe non funzionare ;
    - il mio lab in pratica non esiste più ; avevo pensato ad una soluzione molto più semplice , ma non posso provarla , per cui ho dovuto pensare a qualcosa di più complicato ma che dovrebbe funzionare al 95% senza fare test.
    Sul circuito troverai una resistenza da 22 Ohm in parallelo ad un diodo ( non l'ho siglato , è identico a quello che stà in serie all'uscita ) che stabilisce la corrente alla quale si dovrebbe accendere il led di fine carica in circa 15 milliAmpere ; considera che il gruppo relativo all' LM si ciuccia comunque già 10 milliAmpere , quindi significa che se a fine carica sulla batteria continuano ad andare più di 5 milliAmpere , il led di fine carica non ti si accenderà mai , in questo caso dovrai sperimentalmente ridurre la resistenza da 22 Ohm a 18 , 15 , 12 ; se ancora non dovesse andare , c'è qualcosa che non và e la prima cosa da fare è collegare un amperometro in serie alla betteria per verificare , a fine carica, quanta corrente scorre nella batteria.
    La modifica funziona così : quando accendi il circuito , il led di fine carica è ACCESO ; quando colleghi la batteria il led SI SPEGNE e si riaccenderà a fine carica.

    Ciao.[AIUTO] Led fine carica su caricabatterie-mattew.jpg
    EX PcTuner Staff
    --------------------------------------
    Prima di scrivere , controlla che il cervello sia collegato
    La vita è una tempesta e prenderlo dove fà male è un lampo ( UCCELLONE DOCET )
    Il tempo è sempre poco , usalo bene
    Non polemizzare inutilmente e ricorda che esistono i PVT
    Rispetta e sarai rispettato ; non chiedere le tesine per la scuola , piuttosto proponi , lavora e sarai aiutato

  6. #6

    Iscritto dal
    11/12/2011
    Messaggi
    58
    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    Si , ora che mi dici dei diodi ricordo bene , scusami ma di acqua sotto i ponti ne è passata tanta , il tempo è tiranno pure per me e la mente non è più quella di una volta.
    Figurati, non c'è mica bisogno di scusarsi, tu aiutavi una infinità di utenti, sarebbe stato impossibile ricordarti. E' vero, è passato tanto tanto tempo, ricordo anche quando diventasti latitante causa vita privata, poi dopo un po' fui io a latitare. In ogni caso è bello reincontrare sul web persone di tanto tempo facon le quali si è smanettato a dovere .


    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    Da come è fatto il circuito , è normale che si comporti nel modo detto da te ; gli 0.6 Volt che usi per il calcolo sono uno standard , nel senso che è il valore al quale il transitor dovrebbe iniziare a condurre ; quello tuo comincia a condurre prima , a 0.55 V , quindi ti falsa leggermente i calcoli.
    La resitenza in parallelo all'uscita mettila da 15 KOhm , anche se in teoria dovrebbe essere inutile , forse a causa dei fili parte una qualche auto-oscillazione , andrebbe fatta una verifica ma non credo sia importante.
    Ti allego una modifica da fare al circuito , ma devo fare un paio di premesse :

    - sono 5 anni , se non più , che non mi capita di progettare qualcosa , quindi quello che ti propongo potrebbe non funzionare ;
    Almeno ci sono buone possibilità che funzioni i miei tentativi invece sono stati vani, anzi sono serviti a rompere ben 2 volte i transistor causa corto effettuato con puntale multimetro grazie a mano tremante e vista annebbiata...maledizione all'età



    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    - il mio lab in pratica non esiste più ;
    Non so se hai notato le foto, mi sono messo a "inciarmare" sul tavolo della cucina. Saldatore, multimetro ecc ecc ecc appoggiati senza manco mettere un panno sotto. Un solo graffio su quel tavolo mi sarebbe costato il divorzio
    Anche questo mi scazza, a parte il tempo, non ho un posto dove mettermi, allora non è che posso tenere un burdello del genere dentro casa. Se qualcosa non va, sono comunque costretto a mettere a posto e rimandare, non c'è manco la serenità di metterti li e provare e riprovare finchè non va.


    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    avevo pensato ad una soluzione molto più semplice , ma non posso provarla , per cui ho dovuto pensare a qualcosa di più complicato ma che dovrebbe funzionare al 95% senza fare test.
    Sul circuito troverai una resistenza da 22 Ohm in parallelo ad un diodo ( non l'ho siglato , è identico a quello che stà in serie all'uscita ) che stabilisce la corrente alla quale si dovrebbe accendere il led di fine carica in circa 15 milliAmpere ; considera che il gruppo relativo all' LM si ciuccia comunque già 10 milliAmpere , quindi significa che se a fine carica sulla batteria continuano ad andare più di 5 milliAmpere , il led di fine carica non ti si accenderà mai , in questo caso dovrai sperimentalmente ridurre la resistenza da 22 Ohm a 18 , 15 , 12 ; se ancora non dovesse andare , c'è qualcosa che non và e la prima cosa da fare è collegare un amperometro in serie alla betteria per verificare , a fine carica, quanta corrente scorre nella batteria.
    La modifica funziona così : quando accendi il circuito , il led di fine carica è ACCESO ; quando colleghi la batteria il led SI SPEGNE e si riaccenderà a fine carica.

    Ciao.Allegato 6770

    Ti ringrazio immensamente, sto fine settimana metto insieme il materiale, dovrei avere tutto a casa, e poi ti faccio sapere.

    Solo due domande:

    1 - il condensatore da un micro sul pin 8, quale devo usare, quello in poliestere va bene?

    2 - la tensione di uscita, come l'ho regolata io va bene o devo scendere a 13.8, cosa mi consigli?

  7. #7

    Iscritto dal
    09/12/2011
    Località
    Ciampino , Roma
    Messaggi
    146
    Quote Originariamente inviato da Matthew Visualizza il messaggio

    1 - il condensatore da un micro sul pin 8, quale devo usare, quello in poliestere va bene?

    2 - la tensione di uscita, come l'ho regolata io va bene o devo scendere a 13.8, cosa mi consigli?
    1 - si , va bene , ma mettilo il più vicino possibile ai pin 4 e 8
    2 - la regolazione và fatta come dici tu , 13.8 se la usi in tampone , 14.4 se la devi usare come la stai usando. Questo in teoria , ma credo che 14.4 vadano bene , lo capiremo solo vivendo
    EX PcTuner Staff
    --------------------------------------
    Prima di scrivere , controlla che il cervello sia collegato
    La vita è una tempesta e prenderlo dove fà male è un lampo ( UCCELLONE DOCET )
    Il tempo è sempre poco , usalo bene
    Non polemizzare inutilmente e ricorda che esistono i PVT
    Rispetta e sarai rispettato ; non chiedere le tesine per la scuola , piuttosto proponi , lavora e sarai aiutato

  8. #8

    Iscritto dal
    11/12/2011
    Messaggi
    58
    PS: invece del BC547 il 2N2222 va bene uguale, vero? Io ho usato quello nello schema.

  9. #9

    Iscritto dal
    09/12/2011
    Località
    Ciampino , Roma
    Messaggi
    146
    Si , per quello che deve fare è lo stesso.
    EX PcTuner Staff
    --------------------------------------
    Prima di scrivere , controlla che il cervello sia collegato
    La vita è una tempesta e prenderlo dove fà male è un lampo ( UCCELLONE DOCET )
    Il tempo è sempre poco , usalo bene
    Non polemizzare inutilmente e ricorda che esistono i PVT
    Rispetta e sarai rispettato ; non chiedere le tesine per la scuola , piuttosto proponi , lavora e sarai aiutato

  10. #10

    Iscritto dal
    11/12/2011
    Messaggi
    58
    Quote Originariamente inviato da Omega3 Visualizza il messaggio
    Si , per quello che deve fare è lo stesso.
    Ok, grazie, da adesso non romperò più le balls fino a realizzazione avvenuta


 
+ Rispondi
Pagina 1 di 6 1 2 3 ... UltimaUltima

Autorizzazioni

  • Non puoi iniziare nuove discussioni
  • Non puoi rispondere alle discussioni
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
Powered by vBulletin™ Version 4.1.5
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved
SEO by vBSEO ©2011, Crawlability, Inc.
Fuso orario: UTC +1, sono le 00:11.